Почему нет php5apache2_4.dll или php5apache2_2.dll

Thread Safe - здесь есть php5apache2_4.dll
 Thread Safe — здесь есть php5apache2_4.dll

Модуль php5apache2_4.dll или php5apache2_2.dll есть только в той версии дистрибутива PHP который устанавливается как модуль Apache, эта версия помечена как Thread Safe. Эту версию дистрибутива так же называют: потокобезопасной или многопоточной.

Модуля php5apache2_4.dll или php5apache2_2.dll нет в версии Non Thread Safe, эта версия была разработана для работы как FastCGI.

Установить PHP для Apache на Windows можно тремя способами: модуль Apache, CGI и FastCGI. FastCGI это развитие технологии CGI.

Если вы ставите PHP как модуль Apache выбирайте дистрибутив Thread Safe в нем есть модуль Apache php5apache2_4.dll или php5apache2_2.dll, в версиях дистрибутива PHP Non Thread Safe этих фалов нет — эту версию PHP следует выбрать если вы ставите PHP как FastCGI.Самого модуля FastCGI в дистрибутиве нет его нужно скачать отдельно.

PHP 5.6 VC11 x86 Non Thread Safe — в этом варианте дистрибутива нет php5apache2_4.dll

PHP 5.6 VC11 x86 Thread Safe — здесь есть php5apache2_4.dll

VC11 — это значит что php собирался в Visual Studio 2012, для его работы нужен распространяемый пакет Visual C++ для Visual Studio 2012

VC9 — php собирался в Visual Studio 2008, для его работы нужен распространяемый пакет Visual C++ для Visual Studio 2008.